A fix has been implemented and we are monitoring the results.
Posted May 28, 2025 - 18:46 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 28, 2025 - 18:00 PDT
Investigating
Microsoft is working on addressing an environment issue that has impacted eSUB Classic services. We are working to restore services as quickly as possible.
Posted May 28, 2025 - 17:47 PDT
This incident affected: eSUB Web Application, Field Works Mobile Application, eSUB Time and Kiosk Mobile Applications, Public API for Integrations, and Email Services.