The file upload issue has been mitigated. We will continue to monitor Microsoft's progress to restore power and services at the impacted data centers.
Posted May 29, 2026 - 09:34 PDT
Monitoring
The file upload issue has been mitigated, but we are monitoring our services since the bulk of the application resides in the impacted data centers.
Posted May 29, 2026 - 09:18 PDT
Identified
We are currently tracking a Microsoft Azure infrastructure outage caused by a datacenter power event, which is impacting storage services. Our team is actively investigating ways to manage the situation and minimize the overall impact on our product. We will provide updates as more information becomes available.