The Microsoft outage has been resolved. Affected eSUB Classic services have been restored.
Posted Jul 23, 2026 - 12:58 PDT
Update
Service Update: Intermittent issues affecting eSUB Classic
We're aware that some eSUB Classic users may currently be experiencing intermittent problems, including difficulty uploading files. This is being caused by an ongoing Microsoft Azure network outage affecting the region where eSUB Classic is hosted.
Microsoft has identified the issue and is actively working to restore service as quickly as possible. The disruption is on Microsoft's side rather than within eSUB.
We're monitoring the situation closely and will provide updates as more information becomes available. We apologize for the inconvenience and thank you for your patience.
Posted Jul 23, 2026 - 11:36 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 23, 2026 - 09:01 PDT
Identified
Starting at 07:44 AM PDT on July 23, 2026, a partial Microsoft Azure outage impacted some of our services. As of the time of this message, those Microsoft Azure services are now back online. We are currently in the process of restoring affected eSUB Classic services.
Posted Jul 23, 2026 - 09:01 PDT
Investigating
We have received reports of not being able to upload files and/or create documents where it is stuck on the processing animation screen. We are actively investigating the issue.