Investigating delayed emails
Incident Report for eSUB Construction Software
Resolved
This incident has been resolved.
Posted Jan 22, 2024 - 17:09 PST
Monitoring
We are monitoring email services.
Posted Jan 22, 2024 - 10:26 PST
Investigating
We are currently investigating delayed emails. This may include email reminders and email delivery.
Posted Jan 22, 2024 - 08:12 PST
This incident affected: Email Services.